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Bar Charts and Beyond: Plot-by-Plot Instructions 
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Get the most out of this toolkit! 

▪ Start with the Word document (“Bar Charts and Beyond: Choosing Data 

Visualizations”)—this guide will help you understand the context behind the plots. 

Read through the parts that are relevant to your interests. 

▪ Open the Excel spreadsheet (“Bar Charts and Beyond: Visualizing in Excel”) and 

locate the sample data for the plot types you are interested in. Start with one or 

two plot types based on your comfort level, data, and available time. 

▪ Refer to this instructions document (“Bar Charts and Beyond: Plot-by-Plot 

Instructions”). Follow the instructions to replicate the example plots using the 

sample data in the spreadsheet. 

Note: These instructions were written using Microsoft Excel version 2411. Other versions’ interfaces may 

differ. 
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Getting Oriented in Excel1 
The plot-specific instructions in this document include references to Excel menus for creating and refining your 

plots. The screenshots below will help you locate these menus. 

 

Insert > Chart Menu 

 
You can find the Insert menu at the top, next to Home. Within the Charts section, outlined in red below, you will 

find the following options: 

▪ Recommended Charts 

▪ The bar chart icon (outlined in yellow) 

▪ The line graph icon (outlined in blue) 

▪ The pie chart icon (outlined in pink) 

▪ The statistic chart icon (outlined in green), which is where you will find boxplots 
 

 
 

 

Format Axis Menu 
 

 
1 Microsoft Excel is a product of the Microsoft Corporation, a for-profit company. This guide and accompanying 
materials were created with Microsoft Excel since it is the most widely used spreadsheet software and an industry 
standard. However, there are free software options (e.g., Google Sheets) that have similar data visualization 
functionality. Neither Switchboard nor the International Rescue Committee has a financial relationship with the 
Microsoft Corporation. 

Reminder! 

Different versions of Excel may organize the menus and features differently. The 

screenshots below give examples of how your screen may look. When in doubt, use 

Excel’s Search feature to locate the menu you need. This document uses the specific 

names of menus and features to help you do this. 

 

For example, if your version of Excel does not have a menu called “Chart Design,” you 

could search for the specific feature that the instructions recommend (e.g., data labels).  
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The Format Axis Menu is where you can adjust the number of tick marks, label spacing, and other axis 

features. You can access it by right-clicking on one of the axes of your plot and then selecting Format Axis 

(outlined in red below). 

 

 
 
This is what the Format Axis menu looks like: 

 

 

 
Right-clicking on different parts of the chart will give you the option to bring up its formatting menu. One 

example is the Format Data Series menu, which looks like this: 
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Fill & Line Menu 
 

Within these formatting menus, you can access the Fill & Line Menu (outlined in red below) to adjust the 

colors. 

 

 
 

 

Chart Design Menu 

 

 
 

The Chart Design Menu (outlined in red) is where you can add data labels and legends via the Add Chart 

Element option (outlined in blue).  
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Section 1 – Excel Plot Basics 
 

Bar Chart 
 

1. Select cells I1 - I2 and I5 on the “Basic Bar, Line, and 

Pie Charts” tab (the Fiscal Year column header, FY21, 

and FY24) and cells L1 - L2 and L5 (the Total Number 

of Participants column header and values for FY21 and 

FY24). You can do this by holding down the Control key 

while clicking on each of those cells. 
 

2. Click “Insert,” then in the Charts section, click the first 

small icon showing columns. (If you hover over it, the 

text will read “Insert Column or Bar Chart.”) Click the 

first option under 2-D Column. 
 
Congratulations! You’ve now created a bar chart. What follows is guidance on adjusting the 

formatting. 
      

3. To change the bar colors, double-click on one of the bars. Select the paint bucket (Fill & Line) icon, 

then click the paint bucket in the Fill menu to change the color. This will change both of the bars. 
 

4. Double-click the automatically generated title and replace it with something descriptive, such as “The 

total number of participants in the program has risen substantially between FY21 and FY24.” Use the 

usual font settings (in the Home menu) to adjust the color, font, and font size as desired. 
 
At this point, you have a plot that shows your data. However, many readers find plots easier to read 

when data points are labeled with their values, minimizing or eliminating the need for gridlines. 

Continue with the instructions here to update your plot accordingly. 
 

5. Click one of the bars, which should highlight both bars on the plot. Go to “Chart Design” and then “Add 

Chart Element.” In the Data Labels menu, select a location for the labels. The example used “Outside 

End.” 
 

6. Because this is a simple plot and the bars are now labeled, you can remove the gridlines and y-axis 

values: In the chart area, click one of the gridlines. This should highlight all of the gridlines. Hit the 

“Backspace” or “Delete” button on your keyboard to remove the gridlines. Do the same with the 

values on the y-axis. 
 

Line Graph 
 

1. Select cells I1 - I5 (the column for Fiscal Year) and 

M1 - M5 (the column for Percent Female). You 

can do this by holding down the Control key when 

you select the second set of cells. 

 

2. Click “Insert,” then in the Charts section, click the 

second small icon on the left showing lines with 

markers. (If you hover over it, the text will read 

“Insert Line or Area Chart.”) Click the fourth option 

under 2-D Line (“Line with Markers”). 
 
Congratulations! You’ve now created a line graph. What follows is guidance on adjusting the 
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formatting. 
      

3. To change the line and marker (data point) colors, double-click on the line. Select the paint bucket (Fill 

& Line) icon, then click the paint bucket in the Fill menu to change the color. You will start off in the 

Line menu. Scroll down and click the paint bucket to select a new color. This will change just the line 

color. Scroll back to the top and select “Markers,” then repeat the color selection process. You may 

select the same color or a different one. 
 

4. In this menu, you may also change the marker size and/or shape. Scroll down in the Fill & Line > 

Markers > Marker Options menu to make these adjustments (under Size and Type, respectively). Note 

that you must first select the “Built-in” radio button to change the size and type of the markers. 
 

5. 4. Double-click the automatically generated title and replace it with something descriptive, such 

as “The percent of participants who are women has risen steadily over the last four years.” Use the 

usual font settings (in the Home menu) to adjust the color, font, and font size as desired. 
 
At this point, you have a plot that shows your data. However, many readers find plots easier to read 

when data points are labeled with their values, minimizing or eliminating the need for gridlines. 

Continue with the instructions here to update your plot accordingly. 
 

6. Click one of the data points, which should highlight all points on the plot. Go to “Chart Design” and 

then “Add Chart Element.” In the Data Labels menu, select a location for the labels. The example used 

“Above.” 
 

7. Because this is a simple plot and the points are now labeled, you can limit the number of gridlines and 

corresponding values on the y-axis: Right-click on the y-axis values and click “Format Axis.” In the Axis 

Options menu (which looks like a bar chart), under Axis Options, change the value of the Major units to 

0.15. This sets the gridlines to appear every 15%. 
 

8. Still in the Format Axis menu, navigate to the Fill & Line (paint bucket) menu. Click one of the gridlines 

in the plot area. Again in the Fill & Line menu, under Line, select a light gray shade for the Color. 

Finally, click on the y-axis values and change the font color to a light gray. (You can do this the way you 

would change the font color in a text box—use the Font menu under Home). 
 

Pie Chart 
 

1. Select cells J1 - K1 (the Number of Men and 

Number of Women headings) and J5 - K5 (the 

values of those columns for FY24). You can do this 

by holding down the Control key when you select 

the second set of cells. 

 

2. Click “Insert,” then in the Charts section, click the 

third small icon on the left, showing a pie chart. (If 

you hover over it, the text will read “Insert Pie or 

Doughnut Chart.”) Click the first option under 2-D Pie. 
 
Congratulations! You’ve now created a pie chart. What follows is guidance on adjusting the 

formatting. 
      

3. To change the pie section colors, double-click on one of the sections. Select the paint bucket (Fill & 

Line) icon, then click the paint bucket in the Fill menu to change the color. This will change the color of 

the section you selected. Repeat this process with the other section, selecting a contrasting color. 
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4. Double-click the automatically generated title and replace it with something descriptive, such as 

“Female clients still barely exceeded one-third of the participant population in FY24.” Use the usual 

font settings (in the Home menu) to adjust the color, font, and font size as desired. 

 
At this point, you have a plot that shows your data. However, many readers find plots easier to read 

when data points are labeled with their values, eliminating the need for a legend. Continue with the 

instructions here to update your plot accordingly. 
  

5. Click on the pie chart and go to “Chart Design” and then “Add Chart Element.” In the Data Labels 

menu, select “Data Callout.” This labels each section of the pie chart with both the value and the 

category (Men/Women). Notice that it automatically converts the values to percentages as well, saving 

you a step! 
  

6. Because this is a simple plot and the sections are now labeled, you can remove the legend. Simply 

click on it and use the Backspace/Delete key on your keyboard to remove it. 
  

7. Finally, you can change the font, font size, and font color of the data labels by clicking one of them and 

navigating to Home > Font, just as you would for a text box. 
 

Section 2 – Using Bar Charts 
 

Change Over Time 

 
1. Create the bar chart: Highlight the data in cells 

B1:E5 (i.e., all of the data – representing Country of 

Origin, FY22, Fy23, and FY24), then click the Insert 

menu. In the Charts area, click “Recommended 

Charts,” then select the clustered column chart. 
 

2. Change the overall color scale: Right-click on the 

leftmost bar (representing Syria in FY22) of the 

graph and select “Format Data Series.” In the Fill & 

Line (paint bucket) menu, change the fill to a light 

gray color. Repeat this with the next two bars (Syria 

FY23 and FY24), choosing a darker gray each time. 
 

3. Change the color scale for one set of bars to make them stand out: Double-click on the leftmost bar 

for Iraq (representing FY22). Single click again on this bar, so it is the only one selected. Right-click on 

it and choose “Format Data Point.” In the Fill & Line (paint bucket) menu, select a color. Repeat this 

with the remaining two bars (Iraq FY23 and FY24), selecting a darker shade of the color each time. 
 

4. Add data labels: To add data labels only to the Iraq data, select each column individually, as done in 

Step 3. For each one, click “Chart Design,” then “Add Chart Element,” and select “Outside End” in the 

Data Labels menu. 
 

5. Make any final formatting adjustments: Refer to the recommendations in the Section 2 tab of the 

spreadsheet for tips. This example included the following steps: 

a. Add a descriptive title, such as “Following increased outreach to the Iraqi community, ESL 

enrollments among this group increased by 570% from FY22 to FY24.” 

b. Change the gridline and axis label colors to light gray. 

c. Decrease the number of gridlines by setting the Major axis units to a value of 45. 
 

6. Finally, give your graph a title that clearly conveys the key takeaway. For example, you may title this 

graph “Following increased outreach to the Iraqi community, ESL enrollments among this group 
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increased by 570% from FY22 to FY24.” 

 

Comparison of A and B Example 1 
 

1. Create the bar chart: Highlight the data in 

cells B1:D5 (i.e., all of the data – Indicator, 

Target, and Actual), then click the Insert 

menu. In the Charts area, click 

“Recommended Charts,” then select the 

clustered bar chart. 
 

2. Add data labels: Click on a bar representing 

the Actual data. Click “Chart Design,” then 

“Add Chart Element.” In the Data Labels 

menu, select “Inside Base.” Repeat this 

process with the Target data, choosing the “Outside End” option. 
 

3. Adjust formatting as desired: Change any fonts and font sizing, if desired. Change the bar color of the 

Actual data (we will adjust the Target data below) by right-clicking on one of the bars, navigating to the 

Fill & Line (paint bucket) menu, and selecting a new color in the Fill and Outline menus. 
 

4. Using formatting, create the “thermometer” effect: Right-click the Target series and choose “Format 

Data Series.” Click the paint bucket (Fill & Line) icon to edit formatting. Under Fill, choose “No Fill” and 

under Border, choose “Solid Line.” Increase the width of the line by a few points and change the color 

if desired. Leave the Actual series bars filled as they are. 
 

5. Overlap the bars: Right-click the Target series and again choose “Format Data Series.” Under Series 

Options > Plot Series On, choose “Secondary Axis.” The bars should now be overlapping, with a second 

axis visible above the chart. Click this axis and delete it. 
 

6. Make any final formatting adjustments: Refer to the recommendations in the Section 2 tab for tips 

(the example plot includes a descriptive title, as recommended in the Section 2 tab). 
 

7. Finally, give your graph a title that clearly conveys the key takeaway. For example, you may title this 

graph “Based on year-to-date data, the job readiness training program is on track to meet or exceed 

its targets.” 

 

Comparison of A and B Example 2 

 
1. This is a combo chart: The quarters are 

visualized using a stacked column and the 

targets using a line with markers. Highlight the 

data in cells B1:G5 (i.e., all of the data – 

Location, Annual Target, Q1, Q2, Q3, and Q4) 

and go to Insert menu. Click “Recommend 

Charts,” then the “All Charts” tab. Select 

“Combo” (bottom left).  
 

2. Select chart type for each series: Use the 

dropdown menus under Chart Type to select 

“Stacked Column” for each series, then click 

“OK.” 
 

3. Rearrange the plot to show the data in the desired form: Click on the newly inserted chart. Click “Chart 

Design,” then “Switch Row/Column.” This results in a stacked column chart in which all four quarters 
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and the annual target are stacked in each column. 
 

4. Keeping the chart selected, go again to “Chart Design” and click “Change Chart Type.” Again under 

Combo, ensure all four quarters have a Chart Type of Stacked Column, but for the Annual Target 

series, choose Line with Markers (the fourth option, indicating a line with square data points on it), 

then click “OK.” 
 

5. Remove the target line: In your chart, right-click the Annual Target line and go to Format Data Series. 

Click the paint bucket (Fill & Line) icon to edit formatting. Under Line, select “No line.” Under Marker, 

go to Marker Options, and select “Built-in.” Under Type, choose the long dash shape. Increase the size 

of the marker and adjust the color as desired. 
 

6. Add data labels: keeping the Annual Target data selected, go to “Chart Design” and open the “Add 

Chart Element” menu. Add Data Labels (this example used the Above Data option). If desired, change 

the font and/or font color in the Home > Font menu (the example bolded the labels to make them 

more visible). 
 

7. Create a color gradient: click the bottom component of one of the bars (representing Franklin). Right-

click and select “Format Data Series,” then in the Fill & Line (paint bucket) menu, choose a fill color. 

Repeat this process for each of the stacked bars, choosing a lighter shade of the base color each 

time. 
 

8. Make any final formatting adjustments: Refer to the recommendations in the Section 2 tab for tips. 

You may also adjust the color for each quarter by right-clicking on one of the relevant sections and 

changing the color in the Fill and Outline menus. This example included the following steps: 

a. Add a descriptive title, such as “Based on year-to-date data, three of the four job sites have 

met or exceeded their targets.” 

b. Change the gridline and axis label colors to light gray. 

c. Decrease the number of gridlines 

by setting the Major axis units to a 

value of 300. 
 
Part of a Whole 
 

1. Create the bar chart: Highlight the data in 

cells C1:F3 (i.e., all of the data – Sex, Full-

time, Part-time, and None), then click the 

Insert menu. In the Charts area, click 

“Recommended Charts,” then “Bar Chart.” 

In the bar chart options, choose 100% Stacked Bar. 
 

2. Switch rows and columns: To achieve a plot in which each bar represents a sex, click on the newly 

inserted chart. Click “Chart Design,” then “Switch Row/Column.” 
 

3. Adjust axis limits as needed: Ensure that the x-axis maximum is 100%. If it is higher, right-click on the 

x-axis and click “Format Axis.” Under Axis Options > Bounds, set the Maximum to 1. 
 

4. Add data labels: Click one of the bars near its lefthand end. This should highlight the largest section of 

the bar and the corresponding section on the other bar. Click “Chart Design,” then “Add Chart 

Element.” Under Data Labels, click “Data Callout.” Right-click one of the callouts and click “Format 

Data Labels.” Under the Label Options menu, uncheck the “Category Name” box and check the 

“Series Name” box instead. (Notice what this does!) 
 

5. Adjust callout formatting: Right-click on one of the callouts and click “Format Data Labels.” Under the 

Fill & Line section, select “No fill” and “No line,” so only the text is visible. Adjust the font and color of 
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the text as desired. 
 

6. Repeat Steps 4 and 5 for each section of the bar, adjusting the chart and/or label size as needed to 

accommodate the label text length. 
 

7. Make any final formatting adjustments: Refer to the recommendations in the Section 2 tab for tips. 

This example included the following steps: 

a. Add a descriptive title, such as “Female clients were more likely than male clients to obtain 

full-time employment.” 

b. Change the gridline and axis label colors to light gray. 

c. Decrease the number of gridlines by setting the Major axis units to a value of 300. 

d. Delete the legend (since the data labels contain this information). 
 

Section 3 – Advanced Charts 
 

Boxplot 

 
1. Create your boxplot: Click the Insert menu. In the Charts area, 

click “Insert Statistic Chart” (the icon looks like a blue 

histogram), then “Box-and-Whisker Plot.” This will bring up a 

blank chart. 
 

2. Add data: Right-click on the chart area and click “Select Data.” 

Under Legend Entries (Series), click “Add.” Click the arrow 

next to Series name and select cell G1 to tell Excel that this 

plot will be of Starting Scores. Click the arrow again to go 

back, then click the arrow next to Series values and select 

cells G2 - G52. Click the arrow again to go back, then click 

“OK.” Under Legend Entries (Series) select “Series1” and then 

click “Remove.” (This is a placeholder that Excel adds when 

you insert a chart without selecting data.) 
 

3. Add data categories: Under Horizontal (Category) Axis Labels, click “Edit.” Select cells D2 - D52 to add 

a sex label to each point. Click “Okay.” You should now have a boxplot showing the starting scores for 

both male and female participants. 
 

4. Format the plot: You are now free to format the plot according to your preference. Below are a few 

steps you may wish to take. Refer to the recommendations in the Sections 2 and 3 tabs for additional 

tips. 
 

5. Remove data point markers: While data point markers can sometimes be useful, they can often cause 

a plot to look cluttered. Remove them by right-clicking on one of the boxplots, then clicking “Format 

Data Series.” Uncheck the box that says “Show inner points.” 
 
Note: The outlier point in the female data remains after taking this step, because it is considered 

separate by Excel. To visually remove outliers, uncheck the “Show outlier points” box in the Format 

Data Series menu. By default, the plot also shows an X indicating the mean value. This can likewise 

be removed by unchecking the corresponding box. 
 

6. Adjust the spacing: Drag the corners of the plot until you are happy with its size and shape. If the two 

boxplots seem too wide or narrow, return to the Format Data Series menu. Increase the Gap Width to 

make the bars narrower, or decrease it to make them wider. 
 
Note: If you’d like to use this tool with your own data, you may want to check out the following tool to 

get your data into a usable format: Preparing for Data Analysis. 

https://www.switchboardta.org/resource/preparing-for-data-analysis/


 

12 

 

Spider Plot 

 
Note: The spreadsheet has a data table set up for you already. 

The instructions below walk you through how to fill it in. 

 

1. Calculate the average score for each need type and 

country: In cell L2, enter this formula: 

“=AVERAGEIF($E$2:$E$268, $K2, F$2:F$268)”. Click 

and drag the bottom right corner of this cell down to 

row 3 and across to column O to populate all of the 

cells. 
 
Note that this formula is calculating the average over 

all cells for which the country of origin matches the value in column E and the need type matches the 

value in row 1. 
 

2. Create the spider plot: Select cells K1 - O3 and click the Insert menu. In the Charts area, click 

“Recommended Charts,” then the “All Charts” tab at the top. From there, you can select “Radar Chart” 

and choose your style (the example is the option with markers). 
 

3. Adjust formatting: Adjust the font, font size, colors, etc. to your liking. You may wish to add a highlight 

color to the axis labels to help them stand out (do this via the Font menu as you would for any other 

text). The example changed the scale on the axis to better show distinctions between the groups. This 

can be achieved by double-clicking on the numbers and changing the minimum and maximum values 

to 1.0 and 3.0, respectively. As you enlarge the plot, you may find that Excel automatically changes the 

number of values along the axis. You can reset these by double-clicking on the numbers and changing 

the value of Major to 0.5 (this ensures that the axis values increase by 0.5 each time). Refer to the 

recommendations in the Sections 2 and 3 tabs for additional tips. 
 
Note: If you’d like to use this tool with your own data, you may want to check out the following tool to 

get your data into a usable format: Preparing for Data Analysis. 

 

Heatmap 

 
1. Set up the country categories: In cells I2 - I8, enter the 

seven countries of origin from column D. A quick way to 

do this would be to enter the following formula in cell 

I2: “=unique(D2:D501)”. 
 

2. Set up the age group categories: In cells J1 - P1, enter 

the seven age groups from column E. 
 

3. Calculate the average literacy level for each country/age group combination: In cell J2, enter the 

following formula: “=AVERAGEIFS($F$2:$F$501, $D$2:$D$501, $I2, $E$2:$E$501, J$1)”. Click and 

drag the bottom right corner of this cell down to row 8 and across to column P to populate all of the 

cells. 
 
Note that this formula is calculating the average over all cells for which the country of origin matches 

the value in column I and the age group matches the value in row 1. 
 

4. Select cells J2 - P8. In the Number section of the Home menu, click the “Decrease Decimal” button 

until the numbers show two decimal places. 
 

1

1.5

2

2.5

3
Housing

Mental

health

Material

needs

Language

skills

Afghanistan Ukraine

https://www.switchboardta.org/resource/preparing-for-data-analysis/
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5. Select cells J2 - P8. In the Home menu, click Conditional Formatting. Select “Color Scales,” then “More 

Rules.” In the bottom of this menu, you can now select a color scale of your choice. The example 

shows the default: a red/orange gradient. 
 

6. Adjust formatting: Change the font, font size and color, cell background for the headings, row height, 

and column width to your liking. The spreadsheet has already been adjusted to increase the row 

height, which helps make the heatmap more readable. Refer to the recommendations in the Sections 

2 and 3 tabs for additional tips. 
 

7. Export your chart as an image: Select cells I1 - P8, then right-click and select Copy (or use Ctrl+C). In 

your Word document or PowerPoint slides, go to the Home menu, then click the arrow under Paste and 

select the Paste as Image option. 
 
Note: If you’d like to use this tool with your own data, you may want to check out the following tool to 

get your data into a usable format: Preparing for Data Analysis. 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The IRC received competitive funding through the U.S. Department of Health and Human Services, Administration for Children and 

Families, Grant #90RB0053. The project is 100% financed by federal funds. The contents of this document are solely the 

responsibility of the authors and do not necessarily represent the official views of the U.S. Department of Health and Human 

Services, Administration for Children and Families.   

https://www.switchboardta.org/resource/preparing-for-data-analysis/

